I'm using textMate to develop ruby code. It's very handy because I can run it just pressing (cmd-R). But by default it's running ruby 1.8.7 and I want 1.9.2 version.

This is the steps to change it:

Find the right path with

~$  which rvm-auto-ruby
~$  which python3.2

Then copy it to TextMate preferences in a new variable called "TM_RUBY", and "TM_PYTHON" as shown below: